Verwendung des Applikationsprogramms

Produktfamilie: Kontroller

Produkttyp: Kontroller

Hersteller: Siemens

Name: Ereignisbaustein N 341

Bestell-Nr.: 5WG1 341-1AB01

Funktionsbeschreibung

Der N 341 ist ein universeller, frei programmierbarer Controllerbaustein für beliebige zeit- und ereignisabhängige Anwendungen in Heim und Gewerbe. Er wird auf einer DIN-Hutschiene aufgerastet und ist sofort über die Datenschiene mit dem KNX EIB verbunden.

Leistungsmerkmale

· Vereinbarung von max. 400 Zeitaufträgen in bis zu 125 Tagesprogrammen

· Die Tagesprogramme können max. 150 Kalendereinträgen zugeordnet werden
(Datum oder Datumsbereich)

· Für periodische Abläufe sind drei verschiedene Perioden vereinbar
(Periodendauer 2 ... 40 Tage)

· Vereinbarung von max. 200 Ereignisaufträgen in bis zu 200 Ereignisprogrammen

· Durch Tages- oder Ereignisprogramme können max. 60 Texte mit einer Länge von wahlweise 6,10 oder 14 Zeichen ausgelöst und auf dem Bus versendet werden

Anwendungsbeispiele

· Beleuchtungsaufgaben im Haus und außerhalb

· Rollladen-, Jalousien- und Markisensteuerung

· Gewächshaus- und Wintergartensteuerung (Temperatur, Feuchte, Zeit, Bewässerung)

· Individuelle Ablaufsteuerung für Automatisierungskomfort
(Heizung, Beleuchtung, Rollladen., ..)

· Life-Style-Programmierung für unterschiedliche Nutzerprofile (Szenensteuerung)

· Sicherheitssteuerung / Anwesenheitssimulation („Bewohntes Haus“)

· Gartenbewässerung / Zisternensteuerung

· Zugangskontrolle / Torsteuerung

Mit Hilfe eines speziellen Zusatztools, das Bestandteil der Siemens Produktdatenbank ist und beim Anwählen des N 341 in der ETS3 automatisch gestartet wird, kann der Benutzer den N 341 komfortabel parametrieren und über den KNX EIB die Parametrierung in den N 341 laden.

Hinweis

Das Applikationsprogramm in der Version 4 kann nur zusammen mit der ETS3 verwendet werden. Für die ETS2 steht weiterhin das Applikationsprogramm in der Version 1 zur Verfügung.


Parameter

Die Parametrierung des Ereignisbausteins N 341 erfolgt mit Hilfe eines Zusatztools, das vollständig in die ETS3 integriert ist und automatisch gestartet wird, sobald wie gewohnt der Parametrierdialog der ETS3 aufgerufen wird.

Parameter, die sich auf das generelle Verhalten des Ereignisbausteins N 341 auswirken, werden auf der Maske „Allgemein“ zusammengefasst.

Das Anlegen und Parametrieren der einzelnen Ereignis- bzw. Zeitprogramme erfolgt in den entsprechenden Masken, die durch einen Klick auf den Namen in der links angezeigten Liste aufgerufen werden.

Das Menü „Importieren / Exportieren“ ermöglicht es, die Projektierung des Ereignisbausteins N 341 in eine Datei zu sichern bzw. aus einer Datei wiederherzustellen. Dadurch ist es möglich, die Daten schnell und bequem von einer älteren Version der Applikation in eine neuere Version zu übernehmen.

Um die genaue Versionsbezeichnung des Zusatztools festzustellen, klickt man mit der rechten Maustaste auf die Titelzeile des Parametrierdialogs und wählt in dem aufklappenden Menü den Punkt „Info“:

„OK“ schließt das Hinweisfenster, „Go“ bringt Sie bei bestehender Internetverbindung auf die Internetseiten der Siemens Gebäudesystemtechnik.


Allgemein

Die Parameter der Maske „Allgemein“ haben folgende Bedeutung:

Parameter

Einstellungen

Verzögerungszeit bei
Wiederanlauf (Zeit)

keine Verzögerung

1 Sekunde

2 Sekunden

5 Sekunden

10 Sekunden

20 Sekunden

30 Sekunden

40 Sekunden

1 Minute

2 Minuten

5 Minuten

Dieser Parameter legt das Wiederanlaufverhalten des Zeitprogramms fest. Erst nach der eingestellten Verzögerungszeit werden Objektwerte ggf. versendet.

Verzögerungszeit bei
Wiederanlauf (Ereignis)

keine Verzögerung

1 Sekunde

2 Sekunden

5 Sekunden

10 Sekunden

20 Sekunden

30 Sekunden

40 Sekunden

1 Minute

2 Minuten

5 Minuten

Dieser Parameter legt das Wiederanlaufverhalten des Ereignisprogramms fest. Erst nach der eingestellten Verzögerungszeit werden Objektwerte ggf. versendet bzw. die Stati abgefragt.

Dies dient einerseits dazu, den abzufragenden Geräten (Objekten) genug Zeit zum Bereitstellen der Objektwerte zu geben, anderseits kann bei Wiederanlauf von allen Busteilnehmern die Buslast so entzerrt werden, das wichtige Meldungen auch als Erstes bearbeitet werden können.

Parameter | Einstellungen
Verzögerungszeit zwischen zwei Abfragetelegrammen | keine Verzögerung 0,2 Sekunden 0,5 Sekunden 1 Sekunde 2 Sekunden 5 Sekunden 10 Sekunden 20 Sekunden 30 Sekunden 40 Sekunden 1 Minute 2 Minuten 5 Minuten
Dieser Parameter bestimmt die Zeit zwischen zwei Abfragetelegrammen von Ereignisprogrammen nach einem Wiederanlauf. Auch dieser Parameter dient zur Kontrolle der Buslast bei einem Wiederanlauf durch die zeitliche Verteilung der Abfragetelegramme. Erst wenn alle Objekte abgefragt wurden, werden die Ereignisprogramme bearbeitet.
Nachfahren bei Busspannungswiederkehr | ab Busspannungsausfall maximal ab Mitternacht
Der Parameter gibt an, ob die Zeitaufträge nach (längerem) Busspannungs-/Netzausfall nur ab Mitternacht des aktuellen Tages oder seit Beginn des Busspannungsausfalls nachträglich bearbeitet werden sollen.
Nachfahren ab Zeitdifferenz > | 1 Minute 2 Minuten 5 Minuten 10 Minuten 20 Minuten 30 Minuten 1 Stunde 2 Stunden
Der Parameter gibt an, wie lange der Bus ausgefallen sein muss, damit die nachträgliche Bearbeitung der Zeitaufträge mit größtmöglicher Geschwindigkeit erfolgt. Eine ganze Stunde wird dann in ca. 1,5 Minuten nachgeholt. Bei Busspannungsausfällen kleiner als der eingestellte Wert oder sobald das schnelle Nachfahren soweit fortgeschritten ist, dass die Zeitabweichung entsprechend gering ist, werden die Tagesprogramme bis zum Erreichen der aktuellen Uhrzeit mit der doppelten Geschwindigkeit bearbeitet. Ein Busspannungsausfall von 10 Minuten wird so z. B. innerhalb von 10 Minuten fast unmerklich wieder ausgeglichen. („>“: größer als)

Die Schaltflächen in der untersten Zeile des Parameterfensters haben generell folgende Funktionen:

OK

Beendet die Eingabe und speichert die Daten.

Abbrechen

Bricht die Eingabe ab, geänderte Daten werden nicht gespeichert. Das Betätigen der Taste ‚Esc’ auf der Tastatur hat denselben Effekt.

Standard

Setzt die allgemeinen Parameter auf ihre Standardwerte zurück.

Vor dem Zurücksetzen wird folgender Bestätigungsdialog angezeigt:

Bestätigen zum Zurücksetzen der allgemeinen Parameter mit „Ja“. Alle eingegebenen Daten gehen dadurch verloren! Mit „Nein“ brechen Sie den Vorgang ab.

Dokumentation

Ruft den Windows Standard-Dialog zum Drucken der Dokumentation auf. Der Ausdruck erfolgt generell im Querformat. Ist der Drucker nicht auf Querformat eingestellt, erschein folgender Hinweis:

Wollen Sie dennoch drucken, bestätigen Sie mit „Ja“. Die Information wird jedoch unvollständig ausgedruckt werden. Mit „Nein“ brechen Sie den Vorgang ab.

Einen beispielhaften Ausdruck finden Sie am Ende dieser Beschreibung.

Hilfe

Ruft die seitenspezifische Hilfe auf.


Ereignisse

Ereignis ist beim Zeit- und Ereignisbaustein N 341 der Sammelbegriff für Ereignisprogramme, Ereignisaufträge und Ereignisauslöser.

Ereignisprogramme bestehen aus einer Liste von Ereignisaufträgen, die nacheinander ausgeführt werden.

Ein Ereignisauftrag kann das Senden eines Telegramms mit einem fast beliebigen Wert oder auch von Text auf den KNX EIB auslösen, oder aber auf ein anderes Zeit- oder Ereignisprogramm wirken. Ein Ereignisauftrag kann jeweils nur einem Ereignisprogramm zugeordnet werden.

Ein Ereignisprogramm wird durch eine Ereignisauslösung oder über interne Aufträge aus anderen Zeit- oder Ereignisprogrammen heraus gestartet.

In einer Ereignisauslösung wird die Auslösebedingung für ein Kommunikationsobjekt festgelegt. Wird diese Bedingung erfüllt, wird das zugeordnete Ereignisprogramm gestartet.

Die gezeigten Masken geben die Parametrierung des folgenden Beispiels wieder:

Dabei steht z.B. „Jalousien öffnen“ für den Namen des Ereignisauftrags und „00:00:00:00“ für die Zeit, die von der Ereignisauslösung bis zur Ausführung dieses Ereignisauftrags vergehen soll. „Jalousien zentral“ ist der Name des Kommunikationsobjekts, über das der gewünschte Wert gesendet wird.


Ereignisse Allgemein

Diese Seite zeigt den aktuellen Stand der verwendeten und die maximale Anzahl von Ereignisauslösungen und Ereignisaufträgen und informiert so über die noch zur Verfügung stehenden Ressourcen.


Ereignisprogramme

Beispiele für Ereignisprogramme:

· Beleuchtung Tiefgarage EIN und Rolltor AUF - nur nach berechtigtem Zugang
Beleuchtung Tiefgarage AUS und Rolltor ZU - nur nach einer bestimmten Verzögerungszeit und der Überwachung durch einen Bewegungsmelder

· Beleuchtung Hauseingang EIN - nur bei Unterschreiten eines vorbestimmten Helligkeitswertes
Beleuchtung Hauseingang AUS - nur bei Überschreiten eines vorbestimmten Helligkeitswertes

Diese Maske zeigt eine Übersicht über alle eingegebenen Ereignisprogramme.

Spalte

Beschreibung

Name

gibt den Ereignisprogrammnamen an

Anzahl Aufträge

gibt die Anzahl der Ereignisaufträge des jeweiligen Ereignisprogramms an

Verwendung

gibt die Anzahl der Verwendungen des jeweiligen Ereignisprogramms an; ist ein Ereignisprogramm markiert, wird durch einen Doppelklick auf „Verwendung“ detailliert angezeigt, wo dieses Ereignisprogramm verwendet wird (siehe auch „Löschen“).

Ein Ereignisprogramm kann in anderen Ereignisprogrammen, mit Ereignisauslösungen oder in Tagesprogrammen verwendet werden.

Standardmäßig sind die Einträge nach der ersten Spalte in aufsteigender Reihenfolge sortiert. Durch einen Klick auf eine Spaltenüberschrift wird die Übersicht entweder erstmalig nach dieser Spalte sortiert, oder die bestehende Sortierrichtung umgekehrt.

Ist der in einer Spalte darzustellende Text länger als die Spalte breit ist, wird dies durch drei Punkte am Ende des sichtbaren Textes angezeigt.

Die Spalten der Übersicht können in ihrer Breite verändert werden. Sollte dadurch nicht mehr die gesamte Übersicht sichtbar sein, wird eine horizontale Bildlaufleiste eingeblendet. Geänderte Spaltenbreiten werden beim Beenden der Parametrierung nicht gespeichert, so dass beim erneuten Aufruf die ursprüngliche Spaltenbreite wieder vorhanden ist.

Werden mehr Ereignisprogramme angelegt, als in dem Fenster dargestellt werden können, wird eine vertikale Bildlaufleiste eingeblendet.

Unterhalb der Übersicht sind grundsätzlich folgende Schaltflächen zur Bearbeitung von Ereignisprogrammen vorhanden, wobei jeweils nur die aktuell verwendbaren Schaltflächen aktiviert (also nicht ausgegraut) sind:

Neu

Neue Ereignisprogramme können durch einen Klick auf diese Schaltfläche angelegt werden. Dazu wird das Fenster zum Ändern von Ereignisprogrammen geöffnet. Erst wenn dieses Fenster durch Betätigen der „OK“-Taste verlassen wird, wird das neue Ereignisprogramm angelegt (siehe Abschnitt „Ereignisaufträge“).

Ist die maximale Anzahl von 200 Ereignisprogrammen oder 200 Ereignisaufträgen erreicht, wird diese Schaltfläche deaktiviert.

Ändern

Ist ein Ereignisprogramm markiert, kann es durch Betätigen dieser Schaltfläche bearbeitet werden. Ein Doppelklick auf das Ereignisprogramm ruft ebenfalls den Dialog zum Bearbeiten auf.

Kopieren

Ist ein Ereignisprogramm markiert, kann es über diese Schaltfläche kopiert werden. Durch Betätigen der Schaltfläche „Einfügen“ wird daraufhin eine Kopie des markierten Ereignisprogramms erstellt.

Einfügen

Fügt eine Kopie des zuvor kopierten Ereignisprogramms mit dem Namen ‚<Ereignisprogrammname> (n)’ ein. „n“ ist eine laufende Nummer, die bei jeder Kopie erhöht wird.

Alle weiteren Texte erhalten ebenfalls diesen Zusatz, z.B. werden beim Kopieren eines Ereignisprogramms die Namen aller dabei kopierten Ereignisaufträge ebenfalls entsprechend ergänzt.

Ist die maximale Anzahl von 200 Ereignisprogrammen oder 200 Ereignisaufträgen erreicht, wird diese Schaltfläche deaktiviert.

Löschen

Ist ein Ereignisprogramm markiert, kann es durch Betätigen dieser Schaltfläche oder der Löschtaste auf der Tastatur (‚Entf’) gelöscht werden. Beim Löschen von Ereignisprogrammen wird untersucht, ob dieses Ereignisprogramm an einer anderen Stelle in Verwendung ist. Ist das der Fall, erscheint eine Infobox, in der die Stellen angezeigt werden, an denen das Ereignisprogramm benötigt wird. Das Ereignisprogramm kann dann nicht gelöscht werden:

In der Übersicht ist es durch einen Doppelklick auf die Überschrift der Spalte ‚Verwendung’ möglich, alle Stellen anzuzeigen, an denen das markierte Ereignisprogramm verwendet wird:


Ereignisaufträge

Im Fenster Ereignisaufträge werden Ereignisaufträge zu Ereignisprogrammen zusammengestellt. Sollen Ereignisaufträge Telegramme senden, werden hier Kommunikationsobjekte zur Verbindung mit geeigneten EIB-Geräten angelegt (z.B. Jalousieaktoren, Dimmer, Raumtemperaturregler, usw.).

Die Verbindung der Kommunikationsobjekte über Gruppenadressen erfolgt wie gewohnt mit der ETS3 außerhalb der Parametereinstellungen.

In der obersten Zeile des Fensters kann der Name des Ereignisprogramms vom Anwender eingegeben werden. Die Länge des Namens ist auf 50 Zeichen begrenzt.

Die Übersicht beinhaltet folgende Informationen über alle eingegebenen Ereignisaufträge:

Spalte | Beschreibung
Name | gibt den Ereignisauftragnamen an
Verzögerung | Die Zeit zwischen Auslösung des Ereignisprogramms und der Ausführung eines Ereignisauftrags wird an dieser Stelle angezeigt
Typ | Der Typ des Ereignisauftrags ist hier ersichtlich
verwendet | Je nach Befehlstype wird an dieser Stelle das Kommunikationsobjekt oder das verbundene interne Element angezeigt
Wert | Der zu versendende Wert bzw. die für das interne Element gewünschte Aktion wird an dieser Stelle angezeigt
Status | Der Status des Eintrages ist hier ersichtlich

Unterhalb der Übersicht sind folgende Schaltflächen zur Bearbeitung von Ereignisaufträgen vorhanden, wobei jeweils nur die aktuell sinnvollen Schaltflächen verwendbar sind:

Neu | Neue Ereignisaufträge können durch einen Klick auf diese Schaltfläche angelegt werden. Dazu wird das Fenster zum Ändern von Ereignisaufträgen geöffnet. Erst wenn dieses Fenster durch Betätigen der „OK“-Taste verlassen wird, wird der neue Ereignisauftrag angelegt (siehe Abschnitt „Ereignisauftrag“). Ist die maximale Anzahl von 200 Ereignisaufträgen erreicht, wird diese Schaltfläche deaktiviert.
Ändern | Ist ein Ereignisauftrag markiert, kann er durch Betätigen dieser Schaltfläche bearbeitet werden. Ein Doppelklick auf den Ereignisauftrag ruft ebenfalls den Dialog zum Bearbeiten auf.
Kopieren | Ist ein Ereignisauftrag markiert, kann er über diese Schaltfläche kopiert werden. Durch Betätigen der Schaltfläche „Einfügen“ wird daraufhin eine Kopie des markierten Ereignisauftrages erstellt.
Einfügen | Fügt eine Kopie des zuvor kopierten Ereignisauftrages mit dem Namen ‚<Ereignisauftragsname> (n)’ ein. „n“ ist eine laufende Nummer, die bei jeder Kopie erhöht wird. Ist die maximale Anzahl von 200 Ereignisaufträgen erreicht, wird diese Schaltfläche deaktiviert.
Löschen | Ist ein Ereignisauftrag markiert, kann er durch Betätigen dieser Schaltfläche oder der Löschtaste auf der Tastatur (‚Entf’) gelöscht werden.

Am unteren Ende des Fensters stehen folgende Schaltflächen zur Verfügung:

OK | Beendet die Eingabe und übernimmt die Daten des bearbeiteten Ereignisprogramms. Diese Schaltfläche steht nur zur Verfügung, wenn eine sinnvolle Parametrierung vorgenommen wurde, also mindestens ein Ereignisauftrag angelegt wurde.
Abbrechen | Bricht die Eingabe ab, geänderte Daten werden nicht übernommen. Das Betätigen der Taste ‚Esc’ auf der Tastatur hat denselben Effekt.
Hilfe | Ruft die seitenspezifische Hilfe auf.


Ereignisauftrag

Durch ‚Neu’, ‚Ändern’ oder einen Doppelklick gelangt man in einen Dialog, der es ermöglicht, einen neuen Ereignisauftrag anzulegen bzw. den ausgewählten Ereignisauftrag zu ändern:

Im Fenster Ereignisauftrag wird ein neuer Ereignisauftrag angelegt bzw. ein bestehender Ereignisauftrag geändert.

Am unteren Ende des Fensters stehen folgende Schaltflächen zur Verfügung:

OK | Beendet die Eingabe und übernimmt die Daten des bearbeiteten Ereignisauftrags. Diese Schaltfläche steht nur zur Verfügung, wenn eine sinnvolle Parametrierung vorgenommen wurde, also eine Verbindung des Ereignisauftrags zu einem Kommunikationsobjekt oder einer möglichen internen Verwendung definiert wurde.
Abbrechen | Bricht die Eingabe ab, geänderte Daten werden nicht übernommen. Das Betätigen der Taste ‚Esc’ auf der Tastatur hat denselben Effekt.
Hilfe | Ruft die seitenspezifische Hilfe auf.

Die Bearbeitung des Ereignisauftrags erfolgt über folgende Elemente:

Parameter

Einstellungen

Name

Für jeden Ereignisauftrag sollte ein aussagekräftiger Name vergeben werden, die maximal mögliche Länge beträgt 50 Zeichen.

Status

freigegeben

gesperrt

Mit diesem Parameter wird festgelegt, ob dieser Ereignisauftrag nach dem Laden der Parametrierung in den Ereignisbaustein N 341 „freigeben“ ist, d.h. bei einer Ausführung des Ereignisprogramms berücksichtigt wird, oder ob er zuerst „gesperrt“ ist, also vor einer möglichen Ausführung erst noch freigegeben werden muss. Es besteht die Möglichkeit, einen Ereignisauftrag durch einen anderen Ereignis- oder Zeitauftrag freizugeben oder auch zu sperren (siehe Befehlstyp intern).

Verzögerungszeit

Stunden von 0 bis 1

Minuten von 0 bis 59

Sekunden von 0 bis 59

Zehntelsekunden von 0 bis 9

Die Verzögerungszeit bestimmt, wie lange es nach dem Starten des Ereignisprogramms dauern soll, bis dieser Ereignisauftrag bearbeitet wird. Dadurch ist es möglich, dynamisch ablaufende Vorgänge zu realisieren oder durch Eingabe kurzer Zeitabstände die Abarbeitung verschiedener Ereignisaufträge in einer bestimmten Reihenfolge zu erzwingen. Die Eingabe erfolgt im Format Std:Min:Sek, 0.1Sek, die maximal mögliche Verzögerungszeit beträgt 1:49:13,5 Stunden.

Hinweis:

Um zu Verhindern, dass bei zu vielen gleichzeitig auszuführenden Ereignisaufträgen einzelne Telegramme nicht gesendet werden können, sollten nur max. 10 Ereignisaufträge zur gleichen Zeit ausgeführt werden.

Befehlstyp

Intern

Kommunikationsobjekt

Text

Hier wird festgelegt, welchen Befehlstyp der Ereignisauftrag hat. Abhängig von dieser Einstellung wird die Bearbeitung der weiteren Felder dieses Fensters ermöglicht.

Zur Auswahl stehen:

· Intern: Ein interner Auftrag hat nicht direkt ein Telegramm auf dem Bus zur Folge, sondern beeinflusst die Ausführung anderer Teile der Parametrierung. Ein Ereignisauftrag kann z.B. ein anderes Ereignisprogramm starten oder die Abarbeitung eines Tagesprogramms verhindern.

· Kommunikationsobjekt: Der Ereignisauftrag soll über ein Kommunikationsobjekt einen bestimmten Wert auf den Bus senden.

· Text: Der Ereignisauftrag soll über ein Kommunikationsobjekt einen bestimmten Text auf den Bus senden, um diesen z.B. auf einer Anzeige- und Bedieneinheit darzustellen.


Ereignisauftrag_intern

Wurde als Befehlstyp „Intern“ ausgewählt,

werden die Parameter am unteren Ende

des Fensters aktiviert:

Kategorie

Ereignisauslösungen

Ereignisprogramme

Ereignisaufträge

Tagesprogramme

Zeitaufträge

Kalendereinträge

Perioden

Beim Befehlstyp ‚Intern’ wird an dieser Stelle eingetragen, auf welche Art von Elementen des N 341 sich der interne Auftrag bezieht. In Abhängigkeit von diesem Feld stehen in den Feldern ‚Element’ und ‚Kommando’ die vorhandenen Elemente einer Kategorie zur Auswahl. Nur wenn ein Element der ausgewählten Kategorie vorhanden ist, ist eine Bearbeitung der Felder ‚Element’ und ‚Kommando’ möglich.

Element

Je nach ausgewählter Kategorie können in diesem Feld die angelegten Elemente der ausgewählten Kategorie ausgewählt werden. Ist kein Element der gewählten Kategorie vorhanden, wird dieses Feld ausgegraut. Das aktuelle Element wird gekennzeichnet durch ‚dieser Eintrag’.

Kommando (bei Kategorie Ereignisauslösung)

sperren

freigeben

Kommando (bei Kategorie Ereignisprogramm)

sperren

freigeben

programmieren

unterbreche Ereignisprogramm

starte Ereignisprogramm

Kommando (bei Kategorie Ereignisaufträge)

sperren

freigeben

Kommando (bei Kategorie Tagesprogramme)

sperren

freigeben

aktiviere Tagesprogramm

deaktiviere Tagesprogramm

Kommando (bei Kategorie Zeitaufträge)

sperren

freigeben

Kommando (bei Kategorie Kalendereinträge)

sperren

freigeben

Kommando (bei Kategorie Perioden)

sperren

freigeben

Je nach ausgewählter Kategorie können in diesem Feld die für Elemente dieser Kategorie möglichen Aktionen ausgewählt werden. Ist kein Element der gewählten Kategorie vorhanden, wird dieses Feld ausgegraut. Die einzelnen Kommandos haben folgende Bedeutung:

sperren das ausgewählte Element wird zukünftig bei der Programmausführung nicht mehr berücksichtigt

freigeben das ausgewählte Element wird zukünftig bei der Programmausführung wieder berücksichtigt

programmieren die Werte, die das Ereignisprogramm auslösen soll, werden vom Bus gelesen und gespeichert

unterbreche Ereignisprogramm die Abarbeitung des Ereignisprogramms wird sofort beendet

starte Ereignisprogramm wie über einen Ereignisprogrammauslöser wird das Ereignisprogramm gestartet

aktiviere Tagesprogramm das gewählte Tagesprogramm wird am heutigen Tag ausgeführt

deaktiviere Tagesprogramm die Abarbeitung des gewählten Tagesprogramms am heutigen Tag wird beendet


Ereignisauftrag_Kommunikationsobjekt

Wurde als Befehlstyp „Kommunikationsobjekt“ ausgewählt, werden die Parameter

im mittleren Teil des Fensters aktiviert:

Komm-Objekt

An dieser Stelle wird das Kommunikationsobjekt, über das der Wert bzw. der Text auf den Bus gesendet werden soll, ausgewählt und parametriert bzw. ein neues Kommunikationsobjekt angelegt. Dies geschieht durch Betätigen der Schaltflächen „Neu“ bzw. „Ändern“:

Hinweis:

Für Texte können maximal 8 verschiedene Kommunikationsobjekte angelegt werden.

In dem sich öffnenden Fenster kann in der ersten Zeile der Name des Kommunikationsobjekts vergeben werden, die maximal mögliche Länge beträgt 50 Zeichen.

Der Parameter „EIS Typ“ bestimmt die Art des zu verwendenden Kommunikationsobjekts:

EIS 1: 1 bit = Schalten (1/0, ein/aus, freigeben/sperren, Alarm/kein Alarm, richtig/falsch)

EIS 2: 4 bit = relatives Dimmen ( z.B. 1/8 heller, Stop)

EIS 3: 3 Byte = Zeit (z.B. 01:02:03)

EIS 4: 3 Byte = Datum (z.B. 4.Januar 2005)

EIS 5: 2 Byte Fließkomma = physikalischer Wert (Wertebereich -671088 .. 671088)

EIS 6: 8 bit = Skalierung (Wertebereich 0 .. 255, entspricht 0 .. 100 %, bei Eingabe entsprechend umrechnen!)

EIS 8: 2 bit = Zwangsführung (ohne Zwangsführung (aus), ohne Zwangsführung (ein),

zwangsgeführt ausgeschaltet, zwangsgeführt eingeschaltet)

EIS 9: 4 Byte Fließkomma = physikalischer Wert (-999.999.999.999.999.999 .. +9.999.999.999.999.999.999)

EIS 10 ohne Vorzeichen: 16 bit = Zählwerte (Wertebereich 0 .. 65.535)

EIS 10 mit Vorzeichen: 16 bit = Zählwerte (Wertebereich -32.768 .. +32.767)

EIS 11 ohne Vorzeichen: 32 bit = Zählwerte (Wertebereich 0 .. 4.294.967.295)

EIS 11 mit Vorzeichen: 32 bit = Zählwerte (Wertebereich -2.147.483.648 .. 2.147.483.647)

Text: ASCII-Zeichenkette mit 6, 10 oder 14 Zeichen

Ein bereits angelegtes Kommunikationsobjekt wird durch Betätigen der Schaltfläche „Löschen“ gelöscht.

Wert

Beim Befehlstyp „Kommunikationsobjekt“ ist es an dieser Stelle je nach Typ des ausgewählten Kommunikationsobjekts möglich, einen Wert anzugeben, den der Ereignisauftrag versenden soll, wenn es ausgeführt wird. Der verwendbare Wertebereich ist abhängig vom jeweiligen EIS Typ (siehe oben ). Eine Eingabe ist nur möglich, wenn der Befehlstyp ‚Kommunikationsobjekt’ gewählt wurde (siehe oben).

Hinweis:

Der OK Button wird nur dann zugelassen, wenn der Ereignisauftrag vollständig mit sinnvollen Einstellungen versehen wurde. Nur wenn der Dialog mit OK verlassen wird, werden die vorgenommenen Änderungen gespeichert.


Ereignisprogramme2

Nachdem alle Ereignisaufträge für das aktuelle Ereignisprogramm angelegt wurden, sieht die Übersicht des Ereignisprogramms für das Beispiel folgendermaßen aus:


Ereignisauslösungen

Eine Möglichkeit, ein Ereignisprogramm auszuführen, ist die Verwendung eines Kommunikationsobjektes, über das ein bestimmter Wert empfangen werden muss, um die Ausführung der Ereignisaufträge zu starten.

Im Fenster Ereignisauslösungen werden Auslösebedingungen für Ereignisprogramme definiert und Kommunikationsobjekte zur Verbindung mit geeigneten EIB-Geräten angelegt (z.B. Bewegungsmelder, Dämmerungsschalter, Temperaturfühler, Fensterkontakt, usw.). Die Verbindung der Kommunikationsobjekte über Gruppenadressen erfolgt wie gewohnt mit der ETS3 außerhalb der Parametereinstellungen.

Diese Maske zeigt eine Übersicht über alle eingegebenen Ereignisauslösungen:

Spalte | Beschreibung
Name Ereignisauslösung | gibt den Namen der Ereignisauslösung an
Name Komm-Objekt | gibt den Namen des verwendeten Kommunikationsobjekts an
Auslösebedingung | Gibt die logische Bedingung an, die zum Start des Ereignisprogramms erfüllt sein muss
Name Ereignisprogramm | gibt den Namen des zu startenden Ereignisprogramms an

Standardmäßig sind die Einträge nach der ersten Spalte in aufsteigender Reihenfolge sortiert. Durch einen Klick auf eine Spaltenüberschrift wird die Übersicht entweder erstmalig nach dieser Spalte sortiert, oder die bestehende Sortierrichtung umgekehrt.

Ist der in einer Spalte darzustellende Text länger als die Spalte breit ist, wird dies durch drei Punkte am Ende des sichtbaren Textes angezeigt.

Die Spalten der Übersicht können in ihrer Breite verändert werden. Sollte dadurch nicht mehr die gesamte Übersicht sichtbar sein, wird eine horizontale Bildlaufleiste eingeblendet. Geänderte Spaltenbreiten werden beim Beenden der Parametrierung nicht gespeichert, so dass beim erneuten Aufruf die ursprüngliche Spaltenbreite wieder vorhanden ist.

Werden mehr Ereignisauslösungen angelegt, als in dem Fenster dargestellt werden können, wird eine vertikale Bildlaufleiste eingeblendet.

Unterhalb der Übersicht sind folgende Schaltflächen zur Bearbeitung von Ereignisauslösungen vorhanden, wobei jeweils nur die aktuell sinnvollen Schaltflächen verwendbar sind:

Neu | Neue Ereignisauslösungen können durch einen Klick auf diese Schaltfläche angelegt werden. Dazu wird das Fenster zum Ändern von Ereignisauslösungen geöffnet. Erst wenn dieses Fenster durch Betätigen der „OK“-Taste verlassen wird, wird die neue Ereignisauslösung angelegt (siehe unten). Ist die maximale Anzahl von 100 Ereignisauslösungen erreicht, wird diese Schaltfläche deaktiviert.
Ändern | Ist eine Ereignisauslösung markiert, kann sie durch Betätigen dieser Schaltfläche bearbeitet werden. Ein Doppelklick auf die Ereignisauslösung ruft ebenfalls den Dialog zum Bearbeiten auf.
Kopieren | Ist eine Ereignisauslösung markiert, kann sie über diese Schaltfläche kopiert werden. Durch Betätigen der Schaltfläche „Einfügen“ wird daraufhin eine Kopie der markierten Ereignisauslösung erstellt.
Einfügen | Fügt eine Kopie der zuvor kopierten Ereignisauslösung mit dem Namen ‚<Ereignisauslösungsname> (n)’ ein. „n“ ist eine laufende Nummer, die bei jeder Kopie erhöht wird. Ist die maximale Anzahl von 100 Ereignisauslösungen erreicht, wird diese Schaltfläche deaktiviert.
Löschen | Ist eine Ereignisauslösung markiert, kann sie durch Betätigen dieser Schaltfläche oder der Löschtaste auf der Tastatur (‚Entf’) gelöscht werden.


Ereignisauslösungen2

Über den Button ‚Neu’ bzw. ‚Ändern’ gelangt man in die Bearbeitungsseite einer neu anzulegenden bzw. einer ausgewählten Ereignisauslösung:

Im Fenster Ereignisauslösungen wird eine neue Ereignisauslösung angelegt bzw. eine bestehende Ereignisauslösung geändert.

Am unteren Ende des Fensters stehen folgende Schaltflächen zur Verfügung:

OK | Beendet die Eingabe und übernimmt die Daten der bearbeiteten Ereignisauslösung. Diese Schaltfläche steht nur zur Verfügung, wenn eine sinnvolle Parametrierung vorgenommen wurde, also eine Verbindung der Ereignisauslösung zu einem Kommunikationsobjekt und zu einem Ereignisprogramm definiert wurde.
Abbrechen | Bricht die Eingabe ab, geänderte Daten werden nicht übernommen. Das Betätigen der Taste ‚Esc’ auf der Tastatur hat denselben Effekt.
Hilfe | Ruft die seitenspezifische Hilfe auf.

Die Bearbeitung einer Ereignisauslösung erfolgt über folgende Elemente:

Parameter

Einstellungen

Name

Für jede Ereignisauslösung kann ein Name vergeben werden. Der Name kann bis zu 50 Zeichen lang sein.

Status

freigegeben

gesperrt

Mit diesem Parameter wird festgelegt, ob diese Ereignisauslösung nach dem Laden der Parametrierung in den Ereignisbaustein N 341 „freigeben“ ist, d.h. darüber ein Ereignisprogramm ausgelöst werden kann, oder ob sie zuerst „gesperrt“ ist, also vor einer möglichen Berücksichtigung erst noch freigegeben werden muss. Es besteht die Möglichkeit, dieser Ereignisauslösung durch einen Ereignis- oder Zeitauftrag freizugeben oder auch zu sperren.

Komm-Objekte

An dieser Stelle wird das Kommunikationsobjekt, über das der auslösende Wert vom Bus empfangen werden soll, ausgewählt und parametriert bzw. ein neues Kommunikationsobjekt angelegt. Dies geschieht durch Betätigen der Schaltflächen „Neu“ bzw. „Ändern“:

In dem sich öffnenden Fenster kann in der ersten Zeile der Name des Kommunikationsobjekts vergeben werden, die maximal mögliche Länge beträgt 50 Zeichen.

Der Parameter „EIS Typ“ bestimmt die Art des zu verwendenden Kommunikationsobjekts:

EIS 1: 1 bit = Schalten (1/0, ein/aus, freigeben/sperren, Alarm/kein Alarm, richtig/falsch)

EIS 5: 2 Byte Fließkomma = physikalischer Wert (Wertebereich -671088 .. 671088)

EIS 6: 8 bit = Skalierung (Wertebereich 0 .. 255, entspricht 0 .. 100 %, bei Eingabe entsprechend umrechnen!)

EIS 9: 4 Byte Fließkomma = physikalischer Wert (-999.999.999.999.999.999 .. +9.999.999.999.999.999.999)

EIS 10 ohne Vorzeichen: 16 bit = Zählwerte (Wertebereich 0 .. 65.535)

EIS 10 mit Vorzeichen: 16 bit = Zählwerte (Wertebereich -32.768 .. +32.767)

EIS 11 ohne Vorzeichen: 32 bit = Zählwerte (Wertebereich 0 .. 4.294.967.295)

EIS 11 mit Vorzeichen: 32 bit = Zählwerte (Wertebereich -2.147.483.648 .. 2.147.483.647)

Text: ASCII-Zeichenkette mit 6, 10 oder 14 Zeichen

Ein bereits angelegtes Kommunikationsobjekt wird durch Betätigen der Schaltfläche „Löschen“ gelöscht.

Auslösebedingung (für EIS 1)

wenn Wert empfangen

wenn Wert = 0

wenn Wert = 1

wenn Wert von 0 nach 1

wenn Wert von 1 nach 0

An dieser Stelle wird eingestellt, welcher empfangene binäre Telegrammwert zur Auslösung des parametrierten Ereignisprogramms führen soll. Dabei bedeutet:

wenn Wert empfangen jedes empfangene Telegramm führt zur Auslösung des Ereignisprogramms

wenn Wert = 0 Jedes Telegramm mit dem Wert „0“ führt zur Auslösung des Ereignisprogramms

wenn Wert = 1 Jedes Telegramm mit dem Wert „1“ führt zur Auslösung des Ereignisprogramms

wenn Wert von 0 nach 1 Nur beim Wechsel des Werts von „0’“ nach „1“ wird das Ereignisprogramm ausgeführt

wenn Wert von 1 nach 0 Nur beim Wechsel des Werts von „1“ nach „0“ wird das Ereignisprogramm ausgeführt

Parameter

Einstellungen

Auslösebedingung (für EIS 5,6,9,10,11)

wenn Wert empfangen

wenn Wert > Grenzwert

wenn Wert < Grenzwert

bei Grenzwertüberschreitung

bei Grenzwertunterschreitung

wenn Wert = Grenzwert

An dieser Stelle wird eingestellt, welcher empfangene Telegrammwert des jeweiligen EIS-Typs zur Auslösung des parametrierten Ereignisprogramms führen soll. Dabei bedeutet:

wenn Wert empfangen jedes empfangene Telegramm führt zur Auslösung des Ereignisprogramms

wenn Wert > Grenzwert bei jedem Telegrammwert, der größer ist als der unten angegebene Grenzwert, wird das Ereignisprogramm ausgeführt

wenn Wert < Grenzwert bei jedem Telegrammwert, der kleiner ist als der unten angegebene Grenzwert, wird das Ereignisprogramm ausgeführt

bei Grenzwertüberschreitung nur beim ersten Telegrammwert, der größer ist als der unten angegebene Grenzwert, wird das Ereignisprogramm ausgeführt

bei Grenzwertunterschreitung nur beim ersten Telegrammwert, der kleiner ist als der unten angegebene Grenzwert, wird das Ereignisprogramm ausgeführt

wenn Wert = Grenzwert nur wenn der Telegrammwert genau dem unten angegebene Grenzwert entspricht, wird das Ereignisprogramm ausgeführt

Grenzwert (für EIS 5,6,9,10,11)

Ja nach EIS-Typ des ausgewählten Kommunikationsobjekts ist es an dieser Stelle möglich, einen Grenzwert anzugeben. Eine Eingabe ist nur möglich bei Kommunikationsobjekttyp EIS5, 6, 9, 10, 11 und wenn nicht die Auslösebedingung ‚wenn Wert empfangen’ gewählt wurde. Der verwendbare Wertebereich ist abhängig vom jeweiligen EIS Typ (siehe oben ).

Vorbelegung bei Wiederanlauf (für EIS 1)

Objektwert = 0

Objektwert = 1

Vorbelegung bei Wiederanlauf (für EIS 5,6,7,8,9,10,11)

Grenzwert unterschritten

Grenzwert überschritten

In Abhängigkeit des gewählten Objekttyps und der gewählten Auslösebedingung wird an dieser Stelle eine Vorbelegung des Grenzwertvergleichs für den Wiederanlauf angeboten, um z.B. Flankenauswertungen zu ermöglichen. Bei Eingabe einer unlogischen Vorbelegung wird die Auslösebedingung unter Umständen nie oder verspätet erfüllt werden (z.B. Vorbelegung „Grenzwert überschritten“ und Auslösebedingung „bei Grenzwertüberschreitung“).

Ereignisprogramm

Das bei Erfüllung der Auslösebedingung zu startende Ereignisprogramm wird an dieser Stelle eingestellt.

Programm

aufrufen

Komm.-Obj. Wert speichern

Dieser Parameter legt fest, ob bei Erfüllung der Auslösebedingung die aktuellen Objektwerte der in dem ausgewählten Ereignisprogramm verwendeten Kommunikationsobjekte gespeichert werden sollen (vergleichbar mit Szene speichern), oder ob das Ereignisprogramm mit den gespeicherten bzw. parametrierten Werten ausgeführt werden soll (vergleichbar mit Szene auslösen).

nachtriggerbar

Nein

Ja

Die Nachtriggerbarkeit einer Ereignisauslösung ist hier einstellbar. Nachtriggerbar bedeutet, dass bei erneuter Erfüllung der Auslösebedingung die Bearbeitung des zugehörigen Ereignisprogramms ggf. abgebrochen wird und dieses sofort von Anfang an neu ausgeführt wird.

Ist eine Ereignisauslösung nicht nachtriggerbar, kann das zugehörige Ereignisprogramm erst nach der vollständigen Abarbeitung durch diese Ereignisauslösung erneut gestartet werden. Sollte in der Zwischenzeit die Auslösebedingung erfüllt worden sein, wird das Ereignisprogramm nicht automatisch erneut gestartet, jedoch wird der zuletzt empfangene Telegrammwert bei der Grenzwertüberwachung berücksichtigt. Erfüllte Auslösebedingungen können also bei dieser Einstellung unter Umständen unbemerkt bleiben!

Hinweis:

Der OK Button wird nur dann zugelassen, wenn die Ereignisauslösung vollständig mit sinnvollen Einstellungen versehen wurde. Nur wenn der Dialog mit OK verlassen wird, werden die vorgenommenen Änderungen gespeichert.


Zeit

Unter der Überschrift Zeit werden beim Zeit- und Ereignisbaustein N 341 die Parameter für Tagesprogramme, Zeitaufträge, Kalenderprogramme und Perioden zusammengefasst.

Tagesprogramme bestehen aus einer Liste von Zeitaufträgen, die zu festgelegten Uhrzeiten ausgeführt werden.

Ein Zeitauftrag kann das Senden eines Telegramms mit einem fast beliebigen Wert oder auch von Text auf den KNX EIB auslösen, oder aber auf ein anderes Zeit- oder Ereignisprogramm wirken. Ein Zeitauftrag kann jeweils nur einem Tagesprogramm zugeordnet werden.

Ein Tagesprogramm wird durch einen Kalendereintrag, eine Periode oder über interne Aufträge aus anderen Zeit- oder Ereignisprogrammen heraus aktiviert, d.h. am heutigen Tag ausgeführt.

In einem Kalendereintrag wird festgelegt, an welchem Kalendertag oder in welchem Datumsbereich ein bestimmtes Tagesprogramm ausgeführt werden soll und ob gleichzeitig andere Tagesprogramme deaktiviert werden oder parallel dazu ausgeführt werden sollen.

Mit Hilfe von Perioden kann man eine Reihenfolge festlegen, in der unterschiedliche Tagesprogramme ausgeführt werden sollen. Im Gegensatz zu Kalendereinträgen wird aber nicht ein bestimmtes Datum oder ein Datumsbereich für die Ausführung des immer gleichen Tagesprogramms angegeben, sondern festgelegt, von welchem Datum an zyklisch die festgelegte Reihenfolge der Tagesprogramme ausgeführt werden soll. Die Ausführung einer einmal gestarteten Periode kann nur durch das Sperren der Periode über einen internen Auftrag wieder beendet werden.

Durch Kalendereinträge und Perioden realisierbare Zeitsteuerungen sind z.B. Wochenprogramme (Perioden mit 7 Tagen bzw. Vielfachen davon), einmalig oder monatlich bzw. jährlich einmal ausgeführte Tagesprogramme oder auch täglich wiederkehrende Abläufe.

Beispiele für Zeitprogramme:

· Vom 7. Januar bis 25. April wird die Beleuchtung einer Tiefgarage um 6:00 Uhr ein- und um 22:00 Uhr ausgeschaltet.

· Von Montag bis Freitag wird die Beleuchtung eines Hauseingangs um 18:30 Uhr ein- und um 6:00 Uhr ausgeschaltet.

· Vom 1. März bis 31. Oktober wird von Montag bis Freitag die Jalousie eines Schlafzimmers um 6:00 Uhr geöffnet und um 21:30 Uhr geschlossen. Am Samstag und Sonntag wird sie um 8:30 Uhr geöffnet und um 22:00 Uhr geschlossen.


Zeit Allgemein

Diese Seite zeigt den aktuellen Stand der verwendeten und die maximale Anzahl von Zeitaufträgen, Kalendereinträgen, Tagensprogrammen und Perioden.


Tagesprogramm

Tagesprogramme

Diese Maske zeigt eine Übersicht über alle eingegebenen Tagesprogramme.

Spalte

Beschreibung

Name

gibt den Tagesprogrammnamen an

Anzahl Aufträge

gibt die Anzahl der Zeitaufträge des jeweiligen Tagesprogramms an

Verwendung

gibt die Anzahl der Verwendungen des jeweiligen Tagesprogramms an; ist ein Tagesprogramm markiert, wird durch einen Doppelklick auf „Verwendung“ detailliert angezeigt, wo dieses Tagesprogramm verwendet wird (siehe auch „Löschen“).

Ein Tagesprogramm kann von anderen Tagesprogrammen, von Kalendereinträgen, Perioden oder Ereignisprogrammen verwendet werden.

Standardmäßig sind die Einträge nach der ersten Spalte in aufsteigender Reihenfolge sortiert. Durch einen Klick auf eine Spaltenüberschrift wird die Übersicht entweder erstmalig nach dieser Spalte sortiert, oder die bestehende Sortierrichtung umgedreht.

Ist der in einer Spalte darzustellende Text länger als die Spalte breit ist, wird dies durch drei Punkte am Ende des sichtbaren Textes angezeigt.

Die Spalten der Übersicht können in ihrer Breite verändert werden. Sollte dadurch nicht mehr die gesamte Übersicht sichtbar sein, wird eine horizontale Bildlaufleiste eingeblendet. Geänderte Spaltenbreiten werden beim Beenden der Parametrierung nicht gespeichert, so dass beim erneuten Aufruf die ursprüngliche Spaltenbreite wieder vorhanden ist.

Werden mehr Tagesprogramme angelegt, als in dem Fenster dargestellt werden können, wird eine vertikale Bildlaufleiste eingeblendet.

Grundsätzlich sind zur Bearbeitung von Tagesprogrammen folgende Schaltflächen vorhanden, wobei jeweils nur die aktuell sinnvollen Schaltflächen verwendbar sind:

Neu

Neue Tagesprogramme können durch einen Klick auf diese Schaltfläche angelegt werden. Dazu wird das Fenster zum Ändern von Tagesprogrammen geöffnet. Erst wenn dieses Fenster durch Betätigen der „OK“-Taste verlassen wird, wird das neue Tagesprogramm angelegt.
Ist die maximale Anzahl von 125 Tagesprogrammen oder 400 Zeitaufträgen erreicht, wird diese Schaltfläche deaktiviert.

Ändern

Ist ein Tagesprogramm markiert, kann es durch Betätigen dieser Schaltfläche bearbeitet werden. Ein Doppelklick auf das Tagesprogramm ruft ebenfalls den Dialog zum Bearbeiten auf.

Kopieren

Ist ein Tagesprogramm markiert, kann es über diese Schaltfläche kopiert werden. Durch Betätigen der Schaltfläche „Einfügen“ wird daraufhin eine Kopie des markierten Tagesprogramms erstellt.

Einfügen

Fügt eine Kopie des zuvor kopierten Tagesprogramms mit dem Namen ‚<Tagesprogrammname> (n)’ ein. „n“ ist eine laufende Nummer, die bei jeder Kopie erhöht wird.

Ist die maximale Anzahl von 125 Tagesprogrammen oder 400 Zeitaufträgen erreicht, wird diese Schaltfläche deaktiviert.

Löschen

Ist ein Tagesprogramm markiert, kann es durch Betätigen dieser Schaltfläche oder der Löschtaste auf der Tastatur (‚Entf’) gelöscht werden. Beim Löschen von Tagesprogrammen wird untersucht, ob dieses Tagesprogramm an einer anderen Stelle in Verwendung ist. Ist das der Fall, erscheint eine Infobox, in der die Stellen angezeigt werden, an denen das Tagesprogramm benötigt wird. Das Tagesprogramm kann dann nicht gelöscht werden:

In der Übersicht ist es durch einen Doppelklick auf die Überschrift der Spalte ‚Verwendung’ möglich, alle Stellen anzuzeigen, an denen das markierte Tagesprogramm verwendet wird:


Zeitaufträge

Über den Button ‚Neu’ bzw. ‚Ändern’ gelangt man in die Übersicht der Zeitaufträge eines neu anzulegenden bzw. des ausgewählten Tagesprogramms:

Im Fenster Zeitaufträge werden Zeitaufträge zu Tagesprogrammen zusammengestellt. Sollen Zeitaufträge Telegramme senden, werden hier Kommunikationsobjekte zur Verbindung mit geeigneten EIB-Geräten angelegt (z.B. Jalousieaktoren, Dimmer, Raumtemperaturregler, usw.).

Die Verbindung der Kommunikationsobjekte über Gruppenadressen erfolgt wie gewohnt mit der ETS3 außerhalb der Parametereinstellungen.

In der obersten Zeile des Fensters kann der Name des Tagesprogramms vom Anwender eingegeben werden. Die Länge des Namens ist auf 50 Zeichen begrenzt.

Die Übersicht beinhaltet folgende Informationen über alle eingegebenen Zeitaufträge:

Spalte | Beschreibung
Name | gibt den Zeitauftragnamen an
Zeit | Die Uhrzeit der Ausführung des Zeitauftrags wird an dieser Stelle angezeigt
Typ | Der Typ des Zeitauftrags ist hier ersichtlich
Verwendet | Je nach Befehlstyp wird an dieser Stelle das Kommunikationsobjekt oder das verbundene interne Element angezeigt
Wert | Der zu versendende Wert bzw. die für das interne Element gewünschte Aktion wird an dieser Stelle angezeigt
Status | Der Status des Eintrages ist hier ersichtlich
Nachf. | Das Sendeverhalten für diesen Zeitauftrag während des Nachfahrens ist hier ersichtlich

Standardmäßig sind die Einträge nach der Zeit sortiert. Durch einen Klick auf eine Spaltenüberschrift wird die Übersicht entweder erstmalig nach dieser Spalte sortiert, oder die bestehende Sortierrichtung umgedreht.

Ist der in einer Spalte darzustellende Text länger als die Spalte breit ist, wird dies durch drei Punkte am Ende des sichtbaren Textes angezeigt.

Die Spalten der Übersicht können in ihrer Breite verändert werden. Sollte dadurch nicht mehr die gesamte Übersicht sichtbar sein, wird eine horizontale Bildlaufleiste eingeblendet. Geänderte Spaltenbreiten werden beim Beenden der Parametrierung nicht gespeichert, so dass beim erneuten Aufruf die ursprüngliche Spaltenbreite wieder vorhanden ist.

Werden mehr Zeitaufträge angelegt, als in dem Fenster dargestellt werden können, wird eine vertikale Bildlaufleiste eingeblendet.

Unterhalb der Übersicht sind folgende Schaltflächen zur Bearbeitung von Zeitaufträgen vorhanden, wobei jeweils nur die aktuell sinnvollen Schaltflächen verwendbar sind:

Neu | Neue Zeitaufträge können durch einen Klick auf diese Schaltfläche angelegt werden. Dazu wird das Fenster zum Ändern von Zeitaufträgen geöffnet. Erst wenn dieses Fenster durch Betätigen der „OK“-Taste verlassen wird, wird der neue Zeitauftrag angelegt. Ist die maximale Anzahl von 400 Zeitaufträgen erreicht, wird diese Schaltfläche deaktiviert.
Ändern | Ist ein Zeitauftrag markiert, kann er durch Betätigen dieser Schaltfläche bearbeitet werden. Ein Doppelklick auf den Zeitauftrag ruft ebenfalls den Dialog zum Bearbeiten auf.
Kopieren | Ist ein Zeitauftrag markiert, kann er über diese Schaltfläche kopiert werden. Durch Betätigen der Schaltfläche „Einfügen“ wird daraufhin eine Kopie des markierten Zeitauftrags erstellt.
Einfügen | Fügt eine Kopie des zuvor kopierten Zeitauftrags mit dem Namen ‚<Zeitauftragsname> (n)’ ein. „n“ ist eine laufende Nummer, die bei jeder Kopie erhöht wird. Ist die maximale Anzahl von 400 Zeitaufträgen erreicht, wird diese Schaltfläche deaktiviert.
Löschen | Ist ein Zeitauftrag markiert, kann er durch Betätigen dieser Schaltfläche oder der Löschtaste auf der Tastatur (‚Entf’) gelöscht werden.

Am unteren Rand des Fensters stehen folgende Schaltflächen zur Verfügung:

OK | Beendet die Eingabe und übernimmt die Daten des bearbeiteten Tagesprogramms. Diese Schaltfläche steht nur zur Verfügung, wenn eine sinnvolle Parametrierung vorgenommen wurde, also mindestens ein Zeitauftrag angelegt wurde.
Abbrechen | Bricht die Eingabe ab, geänderte Daten werden nicht übernommen. Das Betätigen der Taste ‚Esc’ auf der Tastatur hat denselben Effekt.
Hilfe | Ruft die seitenspezifische Hilfe auf.


Zeitauftrag

Durch ‚Neu’, ‚Ändern’ oder einen Doppelklick gelangt man in einen Dialog, der es ermöglicht, einen neuen Zeitauftrag anzulegen bzw. den ausgewählten Zeitauftrag zu ändern:

Am unteren Ende des Fensters stehen folgende Schaltflächen zur Verfügung:

OK | Beendet die Eingabe und übernimmt die Daten des bearbeiteten Zeitprogramms. Diese Schaltfläche steht nur zur Verfügung, wenn eine sinnvolle Parametrierung vorgenommen wurde, also mindestens ein Zeitauftrag angelegt wurde.
Abbrechen | Bricht die Eingabe ab, geänderte Daten werden nicht übernommen. Das Betätigen der Taste ‚Esc’ auf der Tastatur hat denselben Effekt.
Hilfe | Ruft die seitenspezifische Hilfe auf.

Die Bearbeitung des Zeitauftrags erfolgt über folgende Elemente:

Parameter

Einstellungen

Name

Für jeden Zeitauftrag kann ein Name vergeben werden. Der Name kann bis zu 50 Zeichen lang sein.

Status

freigegeben

gesperrt

Mit diesem Parameter wird festgelegt, ob dieser Zeitauftrag nach dem Laden der Parametrierung in den Ereignisbaustein N 341 „freigeben“ ist, d.h. bei einer Ausführung des Tagesprogramms berücksichtigt wird, oder ob er zuerst „gesperrt“ ist, also vor einer möglichen Ausführung erst noch freigegeben werden muss. Es besteht die Möglichkeit, einen Zeitauftrag durch einen anderen Zeit- oder Ereignisauftrag freizugeben oder auch zu sperren (siehe Befehlstyp intern).

Nachf.

nein

ja

letzter

Mit diesem Parameter wird festgelegt, ob dieser Zeitauftrag nach einem Spannungsausfall bei Busspannungswiederkehr nachgefahren wird, d.h. in der Zwischenzeit versäumte Telegramme nachträglich gesendet werden sollen. „nein“ bedeutet, dieser Zeitauftrag wird beim Nachfahren nicht berücksichtigt, „ja“ heißt, dass jedes Mal, wenn beim Nachfahren der versäumten Aufgaben dieser Zeitauftrag an der Reihe ist, das gewünschte Telegramm gesendet wird, „letzter“ bewirkt, dass erst nach dem Beenden des Nachfahrens der letzte dann gültige Telegrammwert gesendet wird, alle Zwischenwerte werden unterdrückt.

Uhrzeit [Std:Min]

Stunden von 0 bis 23

Minuten von 0 bis 59

Hier wird eingestellt, zu welcher Uhrzeit dieser Zeitauftrag ausgeführt werden soll. Ein Platzhalter („*“) ist an jeder Stelle (Stunden, Minuten) möglich und bedeutet, dass dieser Zeitauftrag zu jeder vollen Stunde oder Minute ausgeführt werden soll.

Befehlstyp

Intern

Kommunikationsobjekt

Text

Hier wird festgelegt, welchen Befehlstyp der Zeitauftrag hat. Abhängig von dieser Einstellung wird die Bearbeitung der weiteren Felder dieses Fensters ermöglicht.

Zur Auswahl stehen:

· Intern: Ein interner Auftrag hat kein direktes Telegramm auf dem Bus zur Folge, sondern beeinflusst die Ausführung anderer Teile der Parametrierung. Ein Zeitauftrag kann z.B. ein Ereignisprogramm starten oder die Abarbeitung eines anderen Tagesprogramms verhindern.

· Kommunikationsobjekt: Der Ereignisauftrag soll über ein Kommunikationsobjekt einen bestimmten Wert auf den Bus senden.

· Text: Der Zeitauftrag soll über ein Kommunikationsobjekt einen bestimmten Text (als EIS-Typ 15) auf den Bus senden, um diesen z.B. auf einer Anzeige- und Bedieneinheit darzustellen.


Zeitauftrag_intern

Wurde als Befehlstyp „Intern“ ausgewählt,

werden die Parameter am unteren Ende

des Fensters aktiviert:

Parameter

Einstellungen

Kategorie

Ereignisauslösungen

Ereignisprogramme

Ereignisaufträge

Tagesprogramme

Zeitaufträge

Kalendereinträge

Perioden

Beim Befehlstyp ‚Intern’ wird an dieser Stelle eingetragen, auf welche Art von Elementen des N 341 sich der interne Auftrag bezieht. In Abhängigkeit von diesem Feld stehen in den Feldern ‚Element’ und ‚Kommando’ die vorhandenen Elemente einer Kategorie zur Auswahl. Nur wenn ein Element der ausgewählten Kategorie vorhanden ist, ist eine Bearbeitung der Felder ‚Element’ und ‚Kommando’ möglich.

Element

Je nach ausgewählter Kategorie können in diesem Feld die angelegten Elemente der ausgewählten Kategorie ausgewählt werden. Ist kein Element der gewählten Kategorie vorhanden, wird dieses Feld ausgegraut. Das aktuelle Element wird gekennzeichnet durch ‚dieser Eintrag’.

Kommando (bei Kategorie Ereignisauslösung)

sperren

freigeben

Kommando (bei Kategorie Ereignisprogramm)

sperren

freigeben

programmieren

unterbreche Ereignisprogramm

starte Ereignisprogramm

Kommando (bei Kategorie Ereignisaufträge)

sperren

freigeben

Kommando (bei Kategorie Tagesprogramme)

sperren

freigeben

programmieren

aktiviere Tagesprogramm

deaktiviere Tagesprogramm

Kommando (bei Kategorie Zeitaufträge)

sperren

freigeben

Kommando (bei Kategorie Kalendereinträge)

sperren

freigeben

Kommando (bei Kategorie Perioden)

sperren

freigeben

Je nach ausgewählter Kategorie können in diesem Feld die für Elemente dieser Kategorie möglichen Aktionen ausgewählt werden. Ist kein Element der gewählten Kategorie vorhanden, wird dieses Feld ausgegraut.

Die einzelnen Kommandos haben folgende Bedeutung:

sperren das ausgewählte Element wird zukünftig bei der Programmausführung nicht mehr berücksichtigt

freigeben das ausgewählte Element wird zukünftig bei der Programmausführung wieder berücksichtigt

programmieren die Werte, die das Ereignisprogramm auslösen soll, werden vom Bus gelesen und gespeichert

unterbreche Ereignisprogramm die Abarbeitung des Ereignisprogramms wird sofort beendet

starte Ereignisprogramm wie über einen Ereignisprogrammauslöser wird das Ereignisprogramm gestartet

aktiviere Tagesprogramm das gewählte Tagesprogramm wird am heutigen Tag ausgeführt

deaktiviere Tagesprogramm die Abarbeitung des gewählten Tagesprogramms am heutigen Tag wird beendet


Zeitauftrag_Kommunikationsobjekte

Wurde als Befehlstyp „Kommunikationsobjekt“

ausgewählt, werden die Parameter

im mittleren Teil des Fensters aktiviert:

Parameter

Einstellungen

Komm-Objekt

An dieser Stelle wird das Kommunikationsobjekt, über das der Wert bzw. der Text auf den Bus gesendet werden soll, ausgewählt und parametriert bzw. ein neues Kommunikationsobjekt angelegt. Dies geschieht durch Betätigen der Schaltflächen „Neu“ bzw. „Ändern“:

Hinweis:

Für Texte können maximal 8 verschiedene Kommunikationsobjekte angelegt werden.

In dem sich öffnenden Fenster kann in der ersten Zeile der Name des Kommunikationsobjekts vergeben werden, die maximal mögliche Länge beträgt 50 Zeichen.

Der Parameter „EIS Typ“ bestimmt die Art des zu verwendenden Kommunikationsobjekts:

EIS 1: 1 bit = Schalten (1/0, ein/aus, freigeben/sperren, Alarm/kein Alarm, richtig/falsch)

EIS 2: 4 bit = relatives Dimmen ( z.B. 1/8 heller, Stop)

EIS 3: 3 Byte = Zeit (z.B. 01:02:03)

EIS 4: 3 Byte = Datum (z.B. 4.Januar 2005)

EIS 5: 2 Byte Fließkomma = physikalischer Wert (Wertebereich -671088 .. 671088)

EIS 6: 8 bit = Skalierung (Wertebereich 0 .. 255, entspricht 0 .. 100 %, bei Eingabe entsprechend umrechnen!)

EIS 8: 2 bit = Zwangsführung (ohne Zwangsführung (aus), ohne Zwangsführung (ein), zwangsgeführt ausgeschaltet, zwangsgeführt eingeschaltet)

EIS 9: 4 Byte Fließkomma = physikalischer Wert (-999.999.999.999.999.999 .. +9.999.999.999.999.999.999)

EIS 10 ohne Vorzeichen: 16 bit = Zählwerte (Wertebereich 0 .. 65.535)

EIS 10 mit Vorzeichen: 16 bit = Zählwerte (Wertebereich -32.768 .. +32.767)

EIS 11 ohne Vorzeichen: 32 bit = Zählwerte (Wertebereich 0 .. 4.294.967.295)

EIS 11 mit Vorzeichen: 32 bit = Zählwerte (Wertebereich -2.147.483.648 .. 2.147.483.647)

Text: ASCII-Zeichenkette mit 6,10 oder 14 Zeichen

Ein bereits angelegtes Kommunikationsobjekt wird durch Betätigen der Schaltfläche „Löschen“ gelöscht.

Wert

Beim Befehlstyp „Kommunikationsobjekt“ ist es an dieser Stelle je nach Typ des ausgewählten Kommunikationsobjekts möglich, einen Wert anzugeben, den das Zeitprogramm zur parametrierten Uhrzeit versenden soll, wenn es ausgeführt wird. Der verwendbare Wertebereich ist abhängig vom jeweiligen EIS Typ (siehe oben ). Eine Eingabe ist nur möglich, wenn der Befehlstyp ‚Kommunikationsobjekt’ gewählt wurde (siehe oben).

Hinweis:

Der OK Button wird nur dann zugelassen, wenn der Zeitauftrag vollständig mit sinnvollen Einstellungen versehen wurde. Nur wenn der Dialog mit OK verlassen wird, werden die vorgenommenen Änderungen gespeichert.


Tagesprogramm2

Nachdem alle Zeitaufträge für das aktuelle Tagesprogramm angelegt wurden, sieht die Übersicht des Tagesprogramms für das Beispiel folgendermaßen aus:


Kalendereinträge

Eine Möglichkeit, ein Tagesprogramm auszuführen, ist die Verwendung eines Kalendereintrags, mit dessen Hilfe ein bestimmtes Datum oder ein Datumsbereich zur einmaligen oder wiederkehrenden Ausführung der Zeitaufträge definiert wird.

Diese Maske zeigt eine Übersicht über alle eingegebenen Kalendereinträge:

Spalte | Beschreibung
Name | gibt den Tagesprogrammnamen an
Datum | Der Zeitpunkt der Ausführung ist an dieser Stelle beschrieben.
Gültig von | Beschreibt den Gültigkeitsbeginn des Zeitauftrages
Gültig bis | Beschreibt das Gültigkeitsende des Zeitauftrages
Tagesprogramm | Der Name des auszuführenden Tagesprogramms wird an dieser Stelle angezeigt
Status | Der Status des Eintrages ist hier ersichtlich

Grundsätzlich sind zur Bearbeitung von Kalendereinträgen folgende Schaltflächen vorhanden, wobei jeweils nur die aktuell sinnvollen Schaltflächen verwendbar sind:

Neu | Neue Kalendereinträge können durch einen Klick auf diese Schaltfläche angelegt werden. Dazu wird das Fenster zum Ändern von Kalendereinträgen geöffnet. Erst wenn dieses Fenster durch Betätigen der „OK“-Taste verlassen wird, wird der neue Kalendereintrag angelegt. Ist die maximale Anzahl von 150 Kalendereinträgen erreicht, wird diese Schaltfläche deaktiviert.
Ändern | Ist ein Kalendereintrag markiert, kann er durch Betätigen dieser Schaltfläche bearbeitet werden. Ein Doppelklick auf den Kalendereintrag ruft ebenfalls den Dialog zum Bearbeiten auf.
Kopieren | Ist ein Kalendereintrag markiert, kann er über diese Schaltfläche kopiert werden. Durch Betätigen der Schaltfläche „Einfügen“ wird daraufhin eine Kopie des markierten Kalendereintrags erstellt.
Einfügen | Fügt eine Kopie des zuvor kopierten Kalendereintrags mit dem Namen ‚<Kalendereintagsname> (n)’ ein. „n“ ist eine laufende Nummer, die bei jeder Kopie erhöht wird. Ist die maximale Anzahl von 150 Kalendereinträgen erreicht, wird diese Schaltfläche deaktiviert.
Löschen | Ist ein Kalendereintrag markiert, kann er durch Betätigen dieser Schaltfläche oder der Löschtaste auf der Tastatur (‚Entf’) gelöscht werden.
Hilfe | Ruft die seitenspezifische Hilfe auf.


Kalendereintrag

Durch ‚Neu’, ‚Ändern’ oder einen Doppelkick gelangt man in einen Dialog, der es ermöglicht, einen neuen Kalendereintrag anzulegen bzw. den ausgewählten Kalendereintrag zu ändern:

Am unteren Ende des Fensters stehen folgende Schaltflächen zur Verfügung:

OK | Beendet die Eingabe und übernimmt die Daten des bearbeiteten Kalendereintrags. Diese Schaltfläche steht nur zur Verfügung, wenn eine sinnvolle Parametrierung vorgenommen wurde.
Abbrechen | Bricht die Eingabe ab, geänderte Daten werden nicht übernommen. Das Betätigen der Taste ‚Esc’ auf der Tastatur hat denselben Effekt.
Hilfe | Ruft die seitenspezifische Hilfe auf.

Die Bearbeitung eines Kalendereintrags erfolgt über folgende Elemente:

Parameter

Einstellungen

Name

Für jeden Kalendereintrag kann ein Name vergeben werden. Der Name kann bis zu 50 Zeichen lang sein.

Status

freigegeben

gesperrt

Ein gesperrter Kalendereintrag wird nicht bearbeitet. Es besteht die Möglichkeit diesen Eintrag durch einen Zeit- oder Ereignisauftrag freizugeben oder auch zu sperren.

Mit diesem Parameter wird festgelegt, ob dieser Kalendereintrag nach dem Laden der Parametrierung in den Ereignisbaustein N 341 „freigeben“ ist, d.h. zur Ausführung des gewünschten Tagesprogramms berücksichtigt wird, oder ob er zuerst „gesperrt“ ist, also vor einer möglichen Ausführung erst noch freigegeben werden muss. Es besteht die Möglichkeit, einen Kalendereintrag durch einen Ereignis- oder Zeitauftrag freizugeben oder auch zu sperren.

Datum

Tag von 1-31 (dynamisch je nach Monat)

Monat von Januar bis Dezember

Jahr von 2003 bis 2089

Dieser Parameter bestimmt das Datum der Ausführung des weiter unten ausgewählten Tagesprogramms. Der letzte wählbare Tag ist abhängig vom jeweiligen Monat und wird ggf. entsprechend korrigiert. Ein Platzhalter („*“) ist an jeder Stelle (Tag, Monat, Jahr) möglich und bedeutet, dass dieses Tagesprogramm täglich, monatlich oder jährlich ausgeführt werden soll. Die Verwendung mehrerer Platzhalter in einem Kalendereintrag ist zulässig, wobei ein Platzhalter beim Tag nur verwendet werden kann, wenn auch beim Monat ein Platzhalter eingesetzt wird, was wiederum voraussetzt, dass auch beim Jahr ein Platzhalter verwendet wird.

Gültig von

Tag von 1-31 (dynamisch)

Monat von Januar bis Dezember

Jahr von 2003 bis 2089

Dieses Feld bestimmt, ab welchem Datum der Kalendereintrag frühestens ausgeführt werden soll. Die Eingabe erfolgt analog zur Eingabe des Datums (siehe oben). Das Gütigkeitsdatum wird nicht auf Plausibilität im Vergleich zu ‚Datum’ und ‚Gültig bis’ geprüft, bei einmaliger Ausführung eines Kalendereintrags (Tag, Monat und Jahr bei Datum sind ausgefüllt) wird dieses Feld ausgegraut.

Gültig bis

Tag von 1-31 (dynamisch)

Monat von Januar bis Dezember

Jahr von 2003 bis 2089

Dieses Feld bestimmt, bis zu welchem Datum der Kalendereintrag höchstens ausgeführt werden soll. Die Eingabe erfolgt analog zur Eingabe des Datums (siehe oben). Das Gütigkeitsdatum wird nicht auf Plausibilität im Vergleich Datum und ‚Gültig von’ geprüft, bei einmaliger Ausführung eines Kalendereintrags (Tag, Monat und Jahr bei Datum sind ausgefüllt) wird dieses Feld ausgegraut.

Perioden sperren

Ja

Nein

Mit diesem Parameter ist es möglich, die Ausführung von Perioden zu sperren, wenn dieses Tagesprogramm aktiv ist. Bei täglichen Aufträgen (Platzhalter bei Tag, Monat und Jahr) ist dieses Feld ausgegraut.

Tägliche Aufrufe sperren

Ja

Nein

Mit diesem Parameter ist es möglich, tägliche Aufrufe zu sperren, wenn dieses Tagesprogramm aktiv ist. Bei täglichen Aufträgen (Platzhalter bei Tag, Monat und Jahr) ist dieses Feld ausgegraut.

Monatliche Aufrufe sperren

Ja

Nein

Mit diesem Parameter ist es möglich, monatliche Aufrufe zu sperren, wenn dieses Tagesprogramm aktiv ist. Bei monatlichen Aufträgen (Platzhalter bei Monat und Jahr) ist dieses Feld ausgegraut.

Jährliche Aufrufe sperren

Ja

Nein

Mit diesem Parameter ist es möglich, jährliche Aufrufe zu sperren, wenn das oben beschriebene Tagesprogramm aktiv ist. Bei jährlichen Aufträgen (Platzhalter nur bei Jahr) ist dieses Feld ausgegraut.

Tagesprogramm ausführen

Das auszuführende Tagesprogramm ist an dieser Stelle zu wählen. Wurde noch kein Tagesprogramm angelegt, ist dieses Feld ausgegraut.

Hinweis:

Der OK Button wird nur dann zugelassen, wenn ein Kalendereintrag vollständig mit sinnvollen Einstellungen versehen wurde. Nur wenn der Dialog mit OK verlassen wird, werden die vorgenommenen Änderungen gespeichert.


Perioden

Eine weitere Möglichkeit, ein Tagesprogramm auszuführen, ist die Verwendung einer Periode, mit deren Hilfe eine feste Abfolge von auszuführenden Zeitaufträge definiert wird, die ab einem bestimmten Datum permanent wiederholt wird. So kann eine Wochenschaltuhr ebenso definiert werden wie jede andere regelmäßig wiederkehrende Abfolge von Tagesabläufen, z.B. im Rahmen eines Schichtplans.

Diese Maske zeigt eine Übersicht über alle eingegebenen Perioden.

Durch ‚Neu’, ‚Ändern’ oder einen Doppelklick gelangt man in einen Dialog, der es ermöglicht, eine neue Periode anzulegen bzw. die ausgewählte Periode zu ändern.

Spalte | Beschreibung
Name | gibt den Periodennamen an
Anzahl Tage | Die Dauer einer Periode in Tagen ist hier ersichtlich
Beginn | An welchem Datum die Periode beginnt wird an dieser Stelle angezeigt
Status | Der Status des Eintrages ist hier ersichtlich

Grundsätzlich sind zur Bearbeitung von Perioden folgende Schaltflächen vorhanden, wobei jeweils nur die aktuell sinnvollen Schaltflächen verwendbar sind:

Neu | Neue Perioden können durch einen Klick auf diese Schaltfläche angelegt werden. Dazu wird das Fenster zum Ändern von Perioden geöffnet. Erst wenn dieses Fenster durch Betätigen der „OK“-Taste verlassen wird, wird eine neue Periode angelegt. Ist die maximale Anzahl von 3 Perioden erreicht, wird diese Schaltfläche deaktiviert.
Ändern | Ist eine Periode markiert, kann sie durch Betätigen dieser Schaltfläche bearbeitet werden. Ein Doppelklick auf die Periode ruft ebenfalls den Dialog zum Bearbeiten auf.
Kopieren | Ist eine Periode markiert, kann sie über diese Schaltfläche kopiert werden. Durch Betätigen der Schaltfläche „Einfügen“ wird daraufhin eine Kopie der markierten Periode erstellt.
Einfügen | Fügt eine Kopie der zuvor kopierten Periode mit dem Namen ‚<Periodenname> (n)’ ein. „n“ ist eine laufende Nummer, die bei jeder Kopie erhöht wird. Ist die maximale Anzahl von 3 Perioden erreicht, wird diese Schaltfläche deaktiviert.
Löschen | Ist eine Periode markiert, kann sie durch Betätigen dieser Schaltfläche oder der Löschtaste auf der Tastatur (‚Entf’) gelöscht werden.
Hilfe | Ruft die seitenspezifische Hilfe auf.


Periode

Durch ‚Neu’, ‚Ändern’ oder einen Doppelkick gelangt man in einen Dialog, der es ermöglicht, eine neue Periode anzulegen bzw. eine ausgewählte Periode zu ändern.

Auf dieser Seite wird die Reihenfolge der für diese Periode zu verwendenden Tagesprogramme dargestellt.

In der obersten Zeile des Fensters kann der Name der Periode vom Anwender eingegeben werden. Die Länge des Namens ist auf 50 Zeichen begrenzt.

Die Übersicht beinhaltet folgende Informationen über alle eingegebenen Zeitaufträge:

Spalte | Beschreibung
Tag | Die Position des jeweiligen Tagesprogramms innerhalb der Periode wird hier angegeben. Bei einer Periodendauer von 7, 14, 21, 28 und 35 Tagen wird der durch das Startdatum vorgegebene Wochentag mit eingeblendet
Name | Der Zeitpunkt des jeweils auszuführenden Tagesprogramms wird an dieser Stelle angezeigt
Tagesprogramm | Hier ist ersichtlich, ob bei Ausführung des jeweiligen Tagesprogramms eine parallele Ausführung von täglich auszuführenden Kalendereinträgen erlaubt ist („freigegeben“) oder nicht („gesperrt“)

Grundsätzlich sind zur Bearbeitung von Perioden folgende Schaltflächen vorhanden, wobei jeweils nur die aktuell sinnvollen Schaltflächen verwendbar sind:

Neu

Bereits angelegte Tagesprogramme können durch einen Klick auf diese Schaltfläche einer Periode zugewiesen werden. Dazu wird das Fenster ‚Tagesprogramm’ zum Ändern von Perioden geöffnet. Erst wenn dieses Fenster durch Betätigen der „OK“-Taste verlassen wird, wird ein neuer Tag für eine Periode angelegt.

Ist die maximale Anzahl von 40 Tagesprogrammen pro Periode erreicht, wird diese Schaltfläche deaktiviert.

Ändern

Ist ein Tag markiert, kann er durch Betätigen dieser Schaltfläche bearbeitet werden. Ein Doppelklick auf den Tag ruft ebenfalls den Dialog zum Bearbeiten auf.

Kopieren

Ist ein Tag markiert, kann er über diese Schaltfläche kopiert werden. Durch Betätigen der Schaltfläche „Einfügen“ wird daraufhin eine Kopie des markierten Tages erstellt.

Einfügen

Fügt eine Kopie des zuvor kopierten Tages ein. Der kopierte Tag wird nun in der Spalte ‚Tag’ mit einer fortlaufenden Nummer angezeigt.

Ist die maximale Anzahl von 40 Tagesprogrammen pro Periode erreicht, wird diese Schaltfläche deaktiviert.

Löschen

Ist ein Tag markiert, kann er durch Betätigen dieser Schaltfläche oder der Löschtaste auf der Tastatur (‚Entf’) gelöscht werden.

Hilfe

Ruft die seitenspezifische Hilfe auf.

Am unteren Rand des Fensters stehen folgende Schaltflächen zur Verfügung:

OK | Beendet die Eingabe und übernimmt die Daten der bearbeiteten Periode. Diese Schaltfläche steht nur zur Verfügung, wenn eine sinnvolle Parametrierung vorgenommen wurde, also mindestens zwei Tage angelegt wurden.
Abbrechen | Bricht die Eingabe ab, geänderte Daten werden nicht übernommen. Das Betätigen der Taste ‚Esc’ auf der Tastatur hat denselben Effekt.
Hilfe | Ruft die seitenspezifische Hilfe auf.


Periode_Tagesprogramm

Durch ‚Neu’, ‚Ändern’ oder einen Doppelklick gelangt man in einen Dialog, der es ermöglicht, einen neuen Tag in einer Periode anzulegen bzw. den ausgewählten Tag zu ändern:

Dieser Dialog fügt der Periode einen neuen Tag hinzu bzw. ändert ihn.

Parameter | Einstellungen
Tagesprogramm |
Hier ist wählbar, welches Tagesprogramm aktiviert werden soll, wenn dieser Tag in der Periode aktiv ist. Durch die Auswahl von „kein Tagesprogramm“ wird an diesem Tag keine spezifische Aktion ausgelöst. Dadurch kann z.B. in einem Wochenprogramm das Wochenende ausgespart werden.
Sperre Tagesprogramm | Nein Ja
An dieser Stelle kann die parallele Ausführung von täglichen Aufträgen gesperrt oder freigegeben werden. Ist oben „kein Tagesprogramm“ ausgewählt, ist dieses Feld ausgegraut.

Am unteren Ende des Fensters stehen zusätzlich folgende Schaltflächen zur Verfügung:

OK | Beendet die Eingabe und übernimmt die Daten des bearbeiteten Tages. Diese Schaltfläche steht nur zur Verfügung, wenn eine sinnvolle Parametrierung vorgenommen wurde.
Abbrechen | Bricht die Eingabe ab, geänderte Daten werden nicht übernommen. Das Betätigen der Taste ‚Esc’ auf der Tastatur hat denselben Effekt.
Hilfe | Ruft die seitenspezifische Hilfe auf.


Kommunikationsobjekte

Die beiden Kommunikationsobjekte für die Masteruhr sind immer vorhanden. Alle weiteren können in den Dialogen Ereignisauftrag, Ereignisauslösung und Zeitauftrag angelegt werden. Der Name von Kommunikationsobjekten ist frei wählbar. Die max. Anzahl von Zeichen beträgt 50. Die Flags Kommunikation, Schreiben, Übertragen und Aktualisieren sind standardmäßig gesetzt.

Die Gesamtanzahl der verfügbaren Kommunikationsobjekte beträgt 255.


Importieren_Exportieren

Importieren / Exportieren

Der Ereignisbaustein N 341 bietet die Möglichkeit, sämtliche vorgenommenen Einstellungen, also alle Bezeichnungen, Parameter und Gruppenadressverbindungen in eine Datei zu exportieren.

Ebenso kann eine exportierte Parametrierung durch einen Importvorgang in den aktuellen Ereignisbaustein N 341 Datenbankeintrag übernommen werden.

Auf diese Art und Weise kann ein Update der ETS oder des Applikationsprogramms durchgeführt werden, ohne anschließend die gesamte Parametrierung wiederholen zu müssen.

Nach dem Betätigen der Schaltfläche „Exportieren“ öffnet sich der Standarddialog zum Speichern von Dateien:

Die Datei wird im sog. XML-Format gespeichert, einem standardisierten Dateiformat, das eine einfache Auswertung der gespeicherten Daten ermöglicht.

Beim Importieren eines XML-Files werden alle evtl. vorher vorgenommenen Eingaben überschrieben. Eine Sicherheitsabfrage verhindert daher ungewollten Datenverlust:

Hinweis

Um einen exportierten Datensatz eines Ereignisbausteins N 341 importieren zu können, sollten alle Gruppenadressen, die in dem betroffenen Ereignisbaustein N 341 benutzt wurden, auch in dem aktuellen Projekt bereits angelegt worden sein.

Nicht vorhandene Gruppenadressen werden zwar angelegt und verknüpft, jedoch sind die ursprünglichen Bezeichnungen der Gruppenadressen unbekannt, so dass eine exakte Wiederherstellung der ursprünglichen Parametrierung in diesem Fall nicht möglich ist!

Werden gleiche Gruppenadressen im Ursprungsprojekt und im aktuellen Projekt unterschiedlich verwendet, kann dies zu einem scheinbaren Fehlverhalten der Installation führen.

Beim Update eines bestehenden Projektes von der ETS2 auf die ETS3 empfiehlt sich folgendes Vorgehen:

· Exportieren der Parametrierungen des in diesem Projekt vorhandenen Ereignisbausteins N 341 (aussagekräftige Namen verwenden, z.B. mit Hinweis auf die phys. Adresse)

· Dazu ist das ETS2 Export-Tool von Siemens (erhältlich unter www.siemens.de/gamma), eine installierte ETS3 Version sowie die entsprechende ETS2-Datenbank und (wenn vorhanden) die N 341-Zusatzdatenbank notwendig.

· Löschen des Ereignisbausteins N 341 im aktuellen Projekt (in ETS2)

· Export des restlichen Projektes

· Import dieses Projektes in die ETS3

· Importieren des neuen Applikationsprogramms des Ereignisbausteins N 341 für die ETS3

· Einfügen des vorher gelöschten Ereignisbausteins N 341

· Import der exportierten Parametrierungen in den jeweiligen „Ereignisbaustein N 341“


Text

Beim Befehlstyp ‚Text’ kann dem ausgewählten Kommunikationsobjekt einer von 60 zur Verfügung stehenden Texten zugewiesen und dieser geändert werden. Dies geschieht durch Betätigen der daneben befindlichen Schaltfläche „Ändern“ oder durch einen Doppelklick auf den Text. Der Text kann 6, 10 oder 14 ASCII-Zeichen lang sein. Kürzere Texte werden zum Senden automatisch mit Leerzeichen auf die entsprechende Länge aufgefüllt. Zum Versenden von Text stehen maximal 8 verschiedene Kommunikationsobjekte zur Verfügung.